Ankündigung

Einklappen
Keine Ankündigung bisher.

"Starke" FPS Drops

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    "Starke" FPS Drops

    Moin liebe Leute,

    ich habe mir vor kurzem einen neuen Pc angeschafft.
    Hier eben ein Auszug der Hardware:

    AMD Ryzen 7 2700 (8x 3,20GHz, TurboBoost bis 4,10GHz) / 16GB DDR4 RAM (2400MHz) /
    512GB SATA-III SSD / 1TB SATA-III HDD / NVIDIA GeForce GTX 1070 Ti (8GB GDDR5) /
    DVD-Brenner / AMD Sockel AM4 Mainboard / Sharkoon T3-W Gehäuse / 550W Netzteil /
    Windows 10 Pro - 64Bit
    AMD Ryzen 7 2700 (8x 3,20GHz, TurboBoost bis 4,10GHz) / 16GB DDR4 RAM (2400MHz) /
    512GB SATA-III SSD / 1TB SATA-III HDD / NVIDIA GeForce GTX 1070 Ti (8GB GDDR5) /
    DVD-Brenner / AMD Sockel AM4 Mainboard / Sharkoon T3-W Gehäuse / 550W Netzteil /
    Windows 10 Pro - 64Bit

    Soweit ich das bis jetzt einschätzen kann, läuft der PC auch recht flüssig (Farcry 5, Warhammer getestet). Nun kommen wir zu meinem "Problem Spiel": Ich habe bei CS Go, für mein Empfinden und die im PC verbaute Hardware, extreme FPS Drops. Es spielt eigentlich keine Rolle wie hoch ich die Max_Fps setze, die Drops befinden sich immer im 40-100er Bereich. Ein kleines Beispiel: Ich setze die Max_Fps auf 244. Im start Menü erreiche ich diese auch genau. Wenn ich mich Ingame befinde geht das auf und ab dann los. Teilweise geh ich hier auf 130 fps runter und springe dann zwischen 130-244 mehr oder weniger hin und her. Dieses Problem habe ich eigentlich bei jeder eingestellten Auflösung.
    Ich muss dazu sagen, dass ich nach cs 1.6 eigentlich komplett mit dem Gaming aufgehört habe und was Hardware, Einstellungen etc. angeht, eher ahnungslos bin. Dennoch sollte hier doch deutlich mehr drin sein und besonders mehr konstante herrschen oder nicht ?
    Als Monitor nutze ich den AOC AGON AG241QX mit einem DP-Kabel.

    Ich habe jetzt schon aus einem anderen Forum erfahren, dass das Verbaute Am4 Mainboard (a320mdgs) völligst falsch ist. Ebenso das ich für den Ryzen 7 gerne 3000 MHz erreichen sollte. Hier wurde aber rein auf die falsch verbaute bzw. nicht harmonierende Hardware eingegangen. Ich habe mich schon durch hunderte Foren gelesen und komme einfach nicht wirklich weiter.

    Also bitte den Part mit der Hardware mal außen vor lassen oder ist es wirklich so, dass ich mit der Hardware keine guten FPS werte bei Cs Go erreichen kann ? Wie oben erwähnt habe ich immer exakt die gleichen drops, egal wie niedrig ich die Grafikeinstellungen runterschraube.
    Ich bedanke mich vorweg fürs Lesen und hoffentlich auch für Tipps :)

    In diesem Sinne Vielen Dank und Liebe Grüße !
    Zuletzt geändert von Atrax249; 12.01.2019, 21:48.

    #2
    Mein letztes AMD System ist ne halbe Ewigkeit her, insofern werde ich mich zum Thema Hardware nicht äußern können. Mal abgesehen davon, dass die starken Drops (denn bei dir klingt es ja schlimmer als die völlig normalen schwankenden FPS bei CS:GO) erstmal danach klingen, dass es etwas mit der CPU und/oder der Graka zu tun haben könnten.

    Hast du mal versucht, während des Spielens Programme wie „Core Temp“ (Temperaturüberwachung des CPU) sowie „CPU-Z“ (Infos über Chipsätze, RAM etc.) oder für die Grakaüberwachung „GPU-Z“, „AMD Overdrive“ oder „GPU Shark“ laufen zu lassen? Falls nicht, hättest du zumindest erste Anhaltspunkte, ob der CPU / GPU z.B. zu heiß werden, wie sie takten usw.

    Dann hattest du noch geschrieben, dass du dich nicht mehr wirklich mit Einstellungen auseinandergesetzt hast. Das ist bei CS:GO kein Hexenwerk mehr. Die vielleicht wichtigsten Befehle für die CS:GO Startoptionen sind eigentlich:

    -console -novid -high -threads 8 -freq 144 +mat_queue_mode 2

    Das sind die Basisdinge, die man drin haben sollte (insbesondere threads und queue_mode).

    Dazu kannst du einen weiteren Befehl für deine CFG benutzen. Den nimmt er allerdings nach jedem Start wieder raus, weshalb ich meine CFG z.B. schreibgeschützt gemacht habe:

    r_dynamic „0“

    Was dieser Befehl konkret bedeutet, kannst du dir ja vielleicht mal ergooglen, in Kurzform hat er was mit der Beleuchtung / Effekten wie Mündungsfeuer usw. zu tun. Standardmäßig ist dieser Befehl auf „1“ gesetzt. Ich hatte bei mir vor Ewigkeiten, als mein System noch neu und up to date war (i5 3570k @ 4,2ghz, 8GB RAM, Radeon HD 7950), zwar problemlos 288 FPS (darauf geforced), in bestimmten Situationen aber massive Drops... ähnlich wie du sie jetzt hast. Und zwar (ich weiss, dass das erstmal blöd klingt) wenn Leute z.B. irgendwo gebangt haben, vor allem durch Metall, z.B. auf de_cache in der T Mitte. Nach längerer Recherche habe ich dann nen Eintrag auf reddit gefunden, der sich genau damit auseinandergesetzt hat... und siehe da: mit r_dynamic „0“ waren die Probleme verschwunden.

    Einen kleinen Nachteil hat der Befehl im Spiel: wenn jemand z.B. in einer Smoke hockt und schießt, siehst du das Mündungsfeuer seiner Waffe nicht mehr. Aber aus meiner Sicht ist dieser Nachteil absolut zu vernachlässigen.

    Du kannst die Startoptionen sowie r_dynamic ja mal ausprobieren und berichten, ob sich dadurch etwas getan hat!

    Kommentar


      #3
      Zitat von floeQLY Beitrag anzeigen
      Mein letztes AMD System ist ne halbe Ewigkeit her, insofern werde ich mich zum Thema Hardware nicht äußern können. Mal abgesehen davon, dass die starken Drops (denn bei dir klingt es ja schlimmer als die völlig normalen schwankenden FPS bei CS:GO) erstmal danach klingen, dass es etwas mit der CPU und/oder der Graka zu tun haben könnten.

      Hast du mal versucht, während des Spielens Programme wie „Core Temp“ (Temperaturüberwachung des CPU) sowie „CPU-Z“ (Infos über Chipsätze, RAM etc.) oder für die Grakaüberwachung „GPU-Z“, „AMD Overdrive“ oder „GPU Shark“ laufen zu lassen? Falls nicht, hättest du zumindest erste Anhaltspunkte, ob der CPU / GPU z.B. zu heiß werden, wie sie takten usw.

      Dann hattest du noch geschrieben, dass du dich nicht mehr wirklich mit Einstellungen auseinandergesetzt hast. Das ist bei CS:GO kein Hexenwerk mehr. Die vielleicht wichtigsten Befehle für die CS:GO Startoptionen sind eigentlich:

      -console -novid -high -threads 8 -freq 144 +mat_queue_mode 2

      Das sind die Basisdinge, die man drin haben sollte (insbesondere threads und queue_mode).

      Dazu kannst du einen weiteren Befehl für deine CFG benutzen. Den nimmt er allerdings nach jedem Start wieder raus, weshalb ich meine CFG z.B. schreibgeschützt gemacht habe:

      r_dynamic „0“

      Was dieser Befehl konkret bedeutet, kannst du dir ja vielleicht mal ergooglen, in Kurzform hat er was mit der Beleuchtung / Effekten wie Mündungsfeuer usw. zu tun. Standardmäßig ist dieser Befehl auf „1“ gesetzt. Ich hatte bei mir vor Ewigkeiten, als mein System noch neu und up to date war (i5 3570k @ 4,2ghz, 8GB RAM, Radeon HD 7950), zwar problemlos 288 FPS (darauf geforced), in bestimmten Situationen aber massive Drops... ähnlich wie du sie jetzt hast. Und zwar (ich weiss, dass das erstmal blöd klingt) wenn Leute z.B. irgendwo gebangt haben, vor allem durch Metall, z.B. auf de_cache in der T Mitte. Nach längerer Recherche habe ich dann nen Eintrag auf reddit gefunden, der sich genau damit auseinandergesetzt hat... und siehe da: mit r_dynamic „0“ waren die Probleme verschwunden.

      Einen kleinen Nachteil hat der Befehl im Spiel: wenn jemand z.B. in einer Smoke hockt und schießt, siehst du das Mündungsfeuer seiner Waffe nicht mehr. Aber aus meiner Sicht ist dieser Nachteil absolut zu vernachlässigen.

      Du kannst die Startoptionen sowie r_dynamic ja mal ausprobieren und berichten, ob sich dadurch etwas getan hat!
      hieß es nicht vor "ewigkeiten" mal, dass man die ganzen startbefehle entfernen soll, da sie die performance in 99% der fälle eher verschlechtern bzw. nichts (mehr) bringen?

      Kommentar


        #4
        Jep, das hieß es bzw. heißt es auch immer noch.

        Da geht probieren aber tatsächlich über studieren. Ich hatte mir, nach ähnlicher Diskussion, mal die Mühe gemacht, das einfach zu testen.

        -high: da konnte ich keine Veränderungen bemerken (FPS-technisch), egal ob der Befehl drin war oder nicht. Da er sich aber eben auch nich negativ bemerkbar gemacht hat, lasse ich ihn weiter drin.

        +mat_queue_mode 2: hier waren bei meinem System definitiv Unterschiede, als ich ihn weggelassen habe... weniger in der FPS Benchmark Map, dafür aber deutlich während des normalen Spielens. Ohne den Befehl hatte ich zwar annähernd identische, aber deutlich unkonstantere FPS und tiefere Drops, was das Spielgefühl maßgeblich negativ beeinflusst hat.

        Letztlich hilft nur: ausprobieren! Diejenigen, die in verschiedensten Foren geschrieben hatten, dass das bei ihnen nix bewirkt (also auch z.B. r_dynamic „0“), werden ja kein Müll erzählt haben. Ich kann nur von meinen Erfahrungen berichten und die sprechen klar FÜR die genannten Startoptionen und r_dynamic „0“.

        Kommentar


          #5
          Ein kleines Update meinerseits:

          Nach Umstellung von Windows 8 auf Windows 10 sowie Grafikkartenwechsel von der Radeon HD7950 auf ne Geforce GTX 1060 habe ich nochmal den FPS Benchmark ohne Startoptionen (abgesehen von mat_queue_mode 2 in der CFG) und mit Startoptionen (also z.B. mit -high oder -threads 4 usw).

          Das Resultat nach OS- und Grafikkartenwechsel ist konträr zu meinem letzten Test (vielleicht nen 1/2 Jahr her):

          FPS mit Startoptionen (siehe oben): 249 FPS
          FPS „ohne“ Startoptionen (aber queue_mode): 330 FPS

          Insofern muss ich mich korrigieren und pfeife auf -high und -threads!

          r_dynamic 0 bleibt! :)

          Kommentar

          Lädt...
          X